Uploaded image for project: 'CMS'
  1. CMS
  2. CMS-2861

[Front search] Sometimes using filters the number of results is not the same

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.1
    • Component/s: None
    • Labels:
      None

      Description

      • I add the front search service with criteria and results on differents pages and search by a tag category
      • I launch search with text "lorem". The execute query is the following :
        +(title:lorem subtitle:lorem subject:lorem keyword:lorem full:lorem) 
        +(tags:PHYSIQUE tags:CHAMPIGNON tags:BIOTECHNOLOGIES tags:SCIENCES_DE_LA_TERRE tags:FINANCE tags:MODELISATION tags:MARKETING tags:MEDECINE tags:MATHEMATIQUES tags:ALIMENTATION)
        

        I have 3 results : 1 news and 2 articles

      • I click on article filter to see the results for articles : I have now 4 results (1 news and 3 articles). In log the execute query is the following :
        +(title:lorem subtitle:lorem subject:lorem keyword:lorem full:lorem)
        

      The tag search crietria is ignored.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              laurence Laurence Aumeunier
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: