Uploaded image for project: 'Runtime'
  1. Runtime
  2. RUNTIME-3265

Upgrade CodeMirror version

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.3.0
    • Fix Version/s: 4.4.0
    • Component/s: None
    • Labels:
      None
    • Sprint:
      4.4 M1

      Description

      We currently use 3.24-ametys-2
      The latest version at this moment is 5.49.0

      (See https://codemirror.net/mode/javascript/index.html)

      It could be very useful to upgrade this dependency as with RUNTIME-3225 resolved, our JS scripts are compatible with ES2015.
      And with the current version of CodeMirror, it does not handle well the backticks (the whole text from a backtick is orange, even though there is a second backtick to 'close' the template literal).
      And maybe some other missing features for ES2015+.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sprieul Simon Prieul (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: